You are here:   Table of contents / App Content / Articles

Troubleshooting your Wordpress connector

There are two distinct WordPress connectors, one for self hosted blogs, and another for "wordpress.com" blogs.

If you use the GoodBarber for WordPress plugin, please check the following:

1. That the IP addresses of our servers are not blacklisted by your Firewall.
These are our IP ranges:  94.23.134.224/27 and 213.251.158.192/27

This corresponds to the following ranges : 
94.23.134.225 to 94.23.134.254
213.251.158.193 to 213.251.158.222


2. If you are using a caching system, you must not cache the API call backs generated by the plugin. The ?gbjson URLs are to be excluded from the cache system.

If your text is truncated: 

Go to the Settings > Reading Settings menu of your WordPress.
In the "Show" field, select Full Text.

Your images are not showing at all, or showing twice:

1. Usually this happens because you have just installed your own domain name for the PWA version of your app.
This can happen because of faulty settings of your domain name, please check it and contact your registrar.


2. If your images are being shown twice: Contact the support and request specific settings for your images (activation of the IDONOTEXIST setting in the custom field variable).


1

1. Verify that you have activated the comments in the settings of the GoodBarber plugin on your site.

2. If the comments are indeed activated on your site, but you still see an error in the sending of comments from your application, verify that you have correctly filled in the source of your Wordpress site in the settings of the page in your back office.
For example, if you have configured the plugin for the Wordpress site as "http://www.mywebsite.com", this URL is the one you must fill in as the page source.
If you enter "http://www.monsite.com/posts" instead of "http://www.monsite.com", this can cause an error in the comments. To display only the page "posts", enter the URL "http://www.monsite.com" and use the category filters.